Excel'de Temel Mantık Fonksiyonları
Ders Başlıkları


Bu başlık altında Excel'de sıklıkla kullanılan mantıksal formülleri toplamaya çalıştım.

1. VE

=VE([1. MANTIKSAL SONUÇ];[2. MANTIKSAL SONUÇ];.....)

Programcılıkta da çok sık kullanılan mantıksal operatörlerden olan VE operatörü verilen bütün şartların sağlanması durumunda DOĞRU sonucunu vermektedir. Örneğin elimizde 10 tane mantıksal sonuç var ve bunlardan 9 u doğru 1 ise yanlış. Bu durumda VE operatörü bize YANLIŞ sonucunu vermektedir.

2. YADA

=YADA([1. MANTIKSAL SONUÇ];[2. MANTIKSAL SONUÇ];.....)

Programcılıkta da çok sık kullanılan mantıksal operatörlerden olan YADA operatörü verilen şartlardan sadece birisinin sağlanması durumunda DOĞRU sonucunu vermektedir. Örneğin elimizde 10 tane mantıksal sonuç var ve bunlardan 9 u yanlış sadece 1'i doğru. Bu durumda VE operatörü bize DOĞRU sonucunu vermektedir.

3. DEĞİL

=DEĞİL(MANTIKSAL SONUÇ)

Programcılıkta da çok sık kullanılan mantıksal operatörlerden olan DEĞİL operatörü verilen mantıksal sonucun tersini döndürmektedir.

4. EĞER

=EĞER(MANTIKSAL SONUÇ;EĞER DOĞRUYSA;EĞER YANLIŞSA)

Excel'de çok sık kullanılan formüllerin başında EĞER gelmektedir. Bu formül daha ziyade hazırladığımız tablolardaki hücrelere bir program gibi karar almasını sağlamaktadır. Daha da açmak gerekirse bu fonksiyon ile elimizdeki mantıksal durumun sonucuna göre herhangi bir işlem yaptırmak isteriz. Zaten fonksiyonun 2. parametresi eğer şart sağlanırsa istenilen sonuç; 3 parametresi ise eğer şart sağlanmazsa istenilen sonuçtur.

5. EĞERHATA

=EĞERHATA(DEĞER;EĞER DEĞER HATALIYSA)

herhalde Excel'de en sık başımıza gelen hata #SAYI>/0 'dır. Bu gibi hatalar daha çok sayının sıfıra bölünmesinden kaynaklanmaktadır. Bu gibi durumlarla başa çıkmak üzere bu fonksiyonu kullanabiliriz.

Hiç yorum yok:

Yorum Gönder



Sıklıkla Kullandığınız Program Hangisi?

Son makaleyi okumak ister misiniz?

XML Sayfasından Dinamik Veri Çekmek



Belirli Bir Hücre Aralığı Formülü?

# İŞLEM
1 Çalışma sayfasında formülü girmek istediğiniz alanı seçin(Örn:A1:A5) .
2 = yada + tuşlarından birine basın.
3 Ardından sonucunu görmek istediğiniz formülü yazıp Ctrl + Shift + Enter tuş kombinasyonuna beraber basın.


Hücre Formülü?

# İŞLEM
1 Çalışma sayfasında formülü girmek istediğiniz hücreyi seçin. (Örnek: A1)
2 = yada + tuşlarından birine basın.
3 Ardından sonucunu görmek istediğiniz formülü yazıp Enter tuşuna basın.